UPGRADE from Proplab Version 3.1 to 3.1 (Build 20)

USD $0.00

Category:

Description

THIS PATCH ONLY WORKS IF YOU HAVE PURCHASED VERSION 3.1 OF PROPLAB-PRO

Select this option to upgrade from Version 3.1 to the latest Build 20. This patch corrects a problem displaying the geographical maps overlaid on top of the Broadcast Coverage Maps. This patch only works for those running Version 3.1. It will not work for those running Version 3.0.

Reviews

There are no reviews yet.

Be the first to review “UPGRADE from Proplab Version 3.1 to 3.1 (Build 20)”